Todays updates - 6 February 2017 (more bugfixes)

Updated on 6 February 2017
> You now get the correct Farming XP when harvesting herbs (instead of 1000 XP each harvest)
> Changed how the inferno adze works when standing on top of something (like a flower, small bush patch, flax, ...). Instead of logs being added to your inventory, they will now get burned but without creating a fire underneath you.
> NPC's in a Player-Owned House dungeon will no longer get stuck between 2 rooms
> Fixed the bug that caused some of the names in your friends list to be shown in your ignore list instead
> Fixed the bug where you were able to add more than 500 friends to your friends list (but those past 500 were removed after relogging)
> Fixed a bug that causes a stack of multiple items (most notoriously potions) to disappear when leaving and re-entering a region
> Fixed a visual bug that sometimes split up a number over multiple lines when checking a shop price (Salve amulet (e) being the most notorious one)
> Removed a revenant dark beast spawn point that was inside a tree (if anyone finds other broken revenant spawns, please report them on the forums, also don't forget to use ::mypos for the coordinates)
> Fixed a bug that caused some option dialogues to misbehave (for example being teleported to a wrong area after getting a warning popup)
> Fixed the chat head when receiving a new slayer task from a slayer master
> Fixed a visual bug where 0 coins would be dropped when 100M tickets are dropped (for example when a Zaros Godsword is dropped on death)
> The black halloween mask no longer requires 10 defence to wear (please let us know if there are other cosmetic items with wrong requirements)
> You can now properly wear a Reindeer Hat again
> The door at the bottom of the Sorcerer's Tower (at the woodcutting area) can no longer be opened, thereby also preventing a glitch with the deposit box
> Fixed the Ancient D'hide Armour Set, which accidentally required an Ancient Cloak instead of Ancient Chaps to complete
> Fixed the ladder at Barrelchest for Ironman Mode players
> Improved the vertical positioning of a couple of interfaces in the fixed client (such as the Castle Wars interface)

I'll try to take care of all remaining bug reports later this week, but either way we've already started our final work on the Avatar bosses (estimated release within 2 weeks), as well as the system to allow other developers to contribute to PkHonor without having full code access!

Ultimate Ironman Mode remains postponed until we've worked out other items (as well as the PoH menagerie to store pets) to allow for alternative inventory space.

Of course, don't forget this weekend's event: Dagannoth Kings! +20% droprates and double pet droprates during the whole weekend, starting in:

Ending in:


Todays updates - 1 February 2017 (more bugfixes)

Back from vacation and ready to kick some more PkHonor ass!

Updated on 1 February 2017
> Ironman Mode players can now benefit from Castle Wars and XP Event bonuses!
> Fixed the Amulet of Glory which didn't allow you to teleport during combat (except to Edgeville)
> Fixed a coin dupe in the Grand Exchange. This dupe only happened in certain edge case scenario's and the amount duped was usually very limited, so players affected by this can keep the excess coins, unless it's an unreasonable amount (10B+), then we request you turn in a portion of the duped cash to your nearest staff member. So far we haven't found any players who have received an excessive amount of cash due to the dupe.
> The Soul Split prayer should no longer apply when you are at 0 HP
> Fixed a couple of missing account logs (related to login attempts & barrows chest drops)

Today was mostly aimed towards fixing the most important bugs. Friday & the weekend will be spent fixing all other smaller bugs that are still in the server.

Furthermore, this weekend there is a double woodcutting & firemaking XP weekend, also for Ironman Mode players! Go get your inferno adzes and go crazy!

Starts in:

Ends in:

And of course, as every month there is a Double Vote Point event, starting in:

And ending in:

Developers blog

New dev system - very soon!

Since there haven't been a lot of actual content updates in the game for the past month, I'd like to take a moment to inform our community a bit about what we've been doing and what that means for PkHonor.

Ever since we came back from vacation, most of our time has been dedicated to working out the new system to give new developers access to their very own testserver. It's progressing quite nicely - several things are already in place and we will soon have our first working prototype. After we...

Bughunter contest - over! Winners yet to be announced!

Considering the fact that there are still a fair amount of (relatively minor) bugs left in the server as a result of the update, I've decided to extend the bughunter contest we've been holding for the past several weeks! I've also decided to increase the rewards and there will be no less than 40 winners!!

The contest will be ongoing until 10 January, after which the winners will be declared and the rewards handed out!
Bughunter contest over in:

Bughunter contest rules & guidelines
> Whenever you encounter an in-game bug, make a post about it on the forums, either as a reply to this thread, or in our in-game bug reports section. Please try to be as specific as possible so we can reproduce this bug.
> Make sure you include your in-game username in one of your bug reports, so I know where to add the credits (if you never state your in-game name in any reports, you will be excluded from the contest)
> The first person to report a bug gets the points for it
> Bugs, glitches or mechanics that are already known to be do not result in any points
> Only one bug report per post to prevent people from cheating by editing their old posts. This means double posting in bug reports is not only allowed but highly recommended (go crazy, anarchists!)
> When two or more people work together to find a bug (or someone finds a bug and asks another to report it), they all get the full amount of points for it
> You get points based on the severity of the bug:
- 1 point for minor bugs, visual glitches & unintended pvm safespots
- 2 points for relatively minor bugs, things that don't work or ID's that are wrong (for example an NPC having the wrong ID or being spawned in the wrong place)
- 3 points for general bugs
- 4 points for major bugs
- 5 points for game-breaking bugs
- 6 points for dupes or massive exploits

The rewards are as follows:

Spoiler: show
#1 - 30000 credits
#2 - 28000 credits
#3 - 26000 credits

#4 - 20000 credits
#5 - 18000 credits
#6 - 16000 credits
#7 - 14000 credits
#8 - 12000 credits
#9 - 10000 credits
#10 - 8000 credits

#11 - 7750 credits
#12 - 7500 credits
#13 - 7250 credits
#14 - 7000 credits
#15 - 6750 credits
#16 - 6500 credits
#17 - 6250 credits
#18 - 6000 credits
#19 - 5750 credits
#20 - 5500 credits
#21 - 5250 credits
#22 - 5000 credits
#23 - 4750 credits
#24 - 4500 credits
#25 - 4250 credits
#26 - 4000 credits
#27 - 3750 credits
#28 - 3500 credits
#29 - 3250 credits
#30 - 3000 credits
#31 - 2750 credits
#32 - 2500 credits
#33 - 2250 credits
#34 - 2000 credits
#35 - 1750 credits
#36 - 1500 credits
#37 - 1250 credits
#38 - 1000 credits
#39 - 750 credits
#40 - 500 credits

Happy hunting!

PS: The currently reported bugs (and those who reported them) are included below. This list is outdated by about a week, so I need to update it yet.
For everyone who has reported new bugs on the forums, but who haven't stated their in-game username yet in any bug reports so far, I'd recommend to edit one of your reports (or - preferably - reply to an existing bug report of yours). You have 7 days to do that. ^^

Current bughunter report:
Spoiler: show
? Nothing can be sold to Junk Store whatsoever (could not reproduce)

- I don't know if chaotics were intentionally made to go down by only 10 charges per death, if so is that a bug? (that's indeed intentional)

> In the fixed client, the right side of chat-box overlay flashes
> Ahrim and Dharok Brothers spawn on the coffin and are unattackable until lured away
> The 1st Black Dragon in Dragons Tele can be safespot Melee'd around the wall
> For UIM gamemode, multiple pet drops hinders inventory space, as there isn't a way to Destroy/Store pets
- All NPC's drop all items and do not include Clue Scrolls (intended testserver behavior)
- Upon noting items on bank (Such as Food/Potions) you must go 1 by 1 instead of "Note X" (intended behavior, but we're open to suggestions for improvement)

Jonas (Pksasaftw)
? You can't rake farming tree patches (could not reproduce)
? You string the crossbow string fast as fk. Like 5 a second. (could not reproduce, speed seems normal. Unless you disable 'make all', then you can do all skilling actions fast which is not a bug)

> If you click twice, after you start the cutting animation, you'll freeze, and then you'll have to move away a bit and click it again once for it to work (Seems to be fixed, but needs more testing)

> The hitsplat stays there too long
> When clicking to pick up items from the floor, your character doesn't walk towards it
> Wise Old Man takes all bones (and manta rays/runes/...) from your inventory, rather than just the ones needed to complete an achievement
> Our names in the chatbox are blue like our text, it should be black.
> Lighting logs crashes the server
> Our bank tab icon show the quantity of an item
> Sir Tiffy Cashien turns his bench when you click on him
> Farming herbs always results in guam leaves
> Can't give a non-degraded Vesta's Chainbody to the wise old man
> when you click on bank and while running you teleport back to same spot, you automatically still go to the bank.
> 2 teleport animations during teleporting
> You can't sell items back to their shops, only to junk store now :/
> the game thinks you got Guam leaves when harvesting any herbs
> There's no lectern for the Pest Invasion quest (the lectern is there after relogging)
> The mage is only facing South
> If you use 'check steps' on the casket from the Pest Invasion, you equip it, and if you dig again you get another 1.
> Draynor mansion doors don't work
> if you use an item on the superportal, it starts to face you, wherever you are
> finished pest invasion quest
> Glitched character location when jumping the wilderness wall + moving at the same time
> Home teletabs are untradeable
> No '1' near noted items
> The Wise Old man turns invisible when standing still.
> When an NPC dies, the other NPC that is behind it thinks that the NPC is still there and gets stuck there for good 10 seconds before he starts to move again
> You can't private message people by right-clicking their name and pressing 'message' or going to FL list and clicking on their names. You have to use ::m-name-message.
> Zombies occasionally get stuck behind the Khazard dude near the fountain.
> Finished the Wise Old Man Achievements
> Some equipment overlaps each other doesn't look right, like Pernix chaps
> Rocky handholds don't bring you back to GWD (intended behavior, works like that on OSRS, but I've made them unusable to avoid confusion)
> Kamil NPC always faces south
> when the statue becomes an entity you can walk through it. Guess that happens with every object when it becomes an entity.
> You can see your cape's stuff\amulets' through Pernix Cowl (same on production, due to too new models)
> Ghost's attack animation is wrong
- If you go in the Pest Control minigame, and then teleport out, it will bug out (not a bug, if there is an ongoing game, then people in the boat will see the game status so they have an idea how long until the next game)
- You can see what attack the Chaos Elemental will do, so you can protect from it with protection prayers if you time it right (intentional behavior)
- oak trees are missing the top (long known, couldn't fix, game engine limitations, idk how jagex did it)
- Problem is with the achievements is that you have to do everything in a line till the rune crossbow. None of the achievement are independent. Kinda annoying. Like if I choose to grow a tree and get the roots before attaching the rune limbs to the yew stock, I won't get the achievement.
(actually, only the achievements that belong togegher, like mine gold ore, smelt gold bar, craft amulet, need to be done in order. But you can first make a cbow and then do the mantas or bones, doesnt matter)

Im on meth
? Everything in the Portal Room I couldn't enter got deleted (could not reproduce)
> You can't remove newly created objects in your PoH until you try to remove something else (should be fixed, needs more testing)

X When running a client in fullscreen on OS X, you cannot type in any other clients you open (probably won't fix)
> OS X resizable doesn't work
> You can drop trade void and other PkP items
> Esc key doesn't clear what you're typing in chat
> Left-clicking public chat will open 'send message'
> Can't cut spiderwebs sometimes
> Using the ladder at the Barrelchests causes you to crawl forever
> The Interface when you create an account is missing the background
> Can't move from the spot on the deep wild ship besides going downstairs
> Going down the ship's ladder will put you one level down in the same spot so you can't move from behind the ladder.
> Clan chat tab is empty when having a pet spawned
> If you don't have a PoH and use Teleport to House spell, your character does the teleport animation and then turns invisible for a few seconds.
> If you have run turned on, it decreases (if you have less than 95 agility) even while standing still.
> You can exit the PIN interface and talk to people by displaying graphic options.
> Cannot note/unnote items as ultimate ironman mode player
> Can't buy comp capes. Just says you don't meet the requirements
> The edgeville lever doesn't teleport you to wildy lever
> Spec bar as Death doesn't function properly. Clicking the bar doesn't use the spec, and operating the ring to spec doesn't delete your spec in the combat interface.
> You can spam throw rotten tomatoes at the Knights in the party room, allowing you to spam the link message when you kill the last one. Also, the formatting of the link is bugged.
> Clan chat names extend past their space.
> Price check screen is missing
> If you change the attack style with the Trident of the seas, it becomes a melee-only weapon. To get it to start maging again, you have to un-equip and re-equip it
> ::skilling teleports you to the room north of the portal.
> Completed the last journey quest
> The overview tab in bank only shows 80 lines of items, so I don't see all of it
> One of the hollow logs don't work at the snow hunter area
> When attempting to catch butterflies, you'll attempt it once and then the butterfly will fly away and your character stays in the same location, making you have to repeatedly click it to continue hunting it. Also, occasionally with imps (so far seems to only be magpies?), it does the same thing with butterflies where you'll attemp to catch it once, then just stand in the same place, continuously turning to look at the imp
> Kyatts don't follow you across pit traps when you jump across them, they just stand on the other side
> Kebbits don't go into deadfall traps
> Falconry hunting doesn't work. When your falcon catches a kebbit, it turns into a chocolate kebbit that you can't pick up
> Spotted Kebbits turn into Castle Wars shop salesman after being caught
> While hunting imps in Puro-Puro, sometimes your character will run into the wheat and get stuck rather than finding the nearest hole in the wheat
> Trying to add bait to a box trap sometimes results in a never-ending cycle of walking on two spaces
> Net traps aren't always lootable
> If you use the last charge in the trident, the trident degrades and unequips before you hit, causing you to deal less damage
> You can only melee max-hit dummies if you are standing directly next to them
> One of the max hit dummies is a undead max-hit dummy which is unattackable
> GE doesn't properly display name of item you're attempting to buy
> Dupe: Relogging creates GE offers that didn't exist before
> Entering your own name when visiting a friend's house bugs you out and makes you invisible
> Dying while crossing wildy ditch messes up your screen
> The map bugs out at a specific place in the desert South-West of the Santay pass
> There's a new Crystal Ball Space in the Study of a PoH - Jagex moved it two squares so all crystal balls should be moved
> For some reason, I can't enter this room in my PoH,
> The staircase to go downstairs no longer works, you just walk on top of it
> Not sure about this one, but shouldn't the minimap only show rooms for the second floor if you're on the second floor
> Familiars don't follow you properly after teleporting close by
> Other players will keep following you (in a glitchy way) after teleporting close by
- You can light logs on fire with a tinderbox really fast (intended behavior)
- It doesn't say when a player logs in/out in your private chat (intentional, to prevent spam - planning on making it an option you can toggle)
- Chaos elemental pet flies and uses his tentacles as wings (not a bug, we got the NPC from OSRS, apparently it floats there too, kinda cool tbh)
- revenants spawn inside the wilderness resource area (not a bug, resource area is wild so the revenants can spawn there. we'll make the area work soon enough)
- Loot floats in certain spots that shouldn't be accessible (not really a bug since this only applies to when you use ::tele, which only honors can use)
- You can inspect logs from the side rather then the end with the hole in it (rather intended behavior, otherwise players might get confused and think objects are bugged)

> I have a Skill hall directly up from this dungeon room, and i have a Rune Display table built in that room, it bugs out and appears in the bottom room as well (should be fixed, needs retesting)
> teleporting using ancients bugs out when using brawling gloves
> using cooked lava eels / raw lava eels on the demon in Entrana doesnt work. (could not reproduce, eels worked)
> casting Tridents spell makes shield and staff disappear (as if you're casting without wearing anything)
> Barbarian village longhall doors are unusable
> Rocks on the other side of Premium Skilling Zone are missing adamant
> Deposit box at the entrana boat doesn't work
> Using any magic spell while having melee item yeilds melee exp, while having range item yields range exp
> Pest Invasion Quest completed
> Korasi spec is supposed to be magic, although it shows a melee hitsplat (only in PVM, not in PVP)
> There is supposed to be a temple for the quest (correcting history)
> Before i got teleported to the temple, i had this weird interface showing up (not worth to fix this one, but thanks for reporting anyway)
> the sailor on port phaymst for the Correcting history quest doesnt take the crystal items (both full or new) + 150m.
> Champions trapdoor + ladder behind me dont work, they are needed for Correcting history quest.
> Correcting history quest done
> Using any spell drains charges from Trident
> Melee hits using the trident also drains charges from the trident
> Energy Transfer on lunars page is bugged, I have 99 magic and it gives a message "You need level 91 magic to cast this spell".
> heal other gives a message that you don't have enough runes
> Clicking on this chaos altar brings up a message in game chat which is related to a quest (cant remember exactly what), I have all quests finished, So I dont believe it should show that message.
> Soul split doesnt heal in PVM combat
> Sitting on chairs in POH doesnt work
> Game asks to build a downward staircase when there's already one
> Frost dragons in POH are graphically bugged. Black Triangles all over
> Spamming 4 on any of morph ring's dialogues teleports you to lvl 55 lever
> Small text bug i noticed, Some items are displayed with K's (In the picture, 126,500k which translates into 126m) and some are displayed with M's (115m)
> You can't repair chaotic equipment at a Repair Stand in a POH workshop
X Building a Quest Hall / Skill Hall that leads upstairs only gives you the option to build more Skill Halls / Quest halls, it should allow you to build a variety of other rooms
> Ring of life still shows in your equipment slot after use (visual)
> Web behind the KBD entrance not working
> Move players who are in the resource area on production
> Squeezing throught the Gnome Course pipes puts you in a state of infinite crawling
> Speccing with Death on dummies reduces spec bar, speccing with any other weapon does not
> Primal is glitched (I've removed it from the game altogether)
- starting the Pest Control quest takes off PkH points and PC points from your account (intended behavior, it does work like that as of several years ago)
- staff of light special doesnt block melee dmg (intended behavior, not a bug, it only blocks 50% dmg - not 100% - but I've improved the message for clarity)
- custom items that are brand new cannot be activated with the special attack button (known, new items aren't implemented yet)
- Korari's spec itself spreads across nearby npcs aswell, its like a barrage (not a bug, that's how Korasi's spec works in multi-combat)
- I noticed that Frost Dragons with the NPC code 10468 are unaggressive, although 10467 are aggressive (not a bug, all frosts in wild are aggressive, all frosts in POH are unaggro)
- Invisibility bug in player-owned houses (known bug)
- There's a lonesome rune rock in lvl 50 wild (intended, Jagex may have added those to OSRS, certainly not a bug but good to know)
- Staircases that go downstairs are graphically bugged (known, it's due to the background being sorta fog-like rather than black. You can also notice in deep wild agility course)

Color x (Troll n roll)
> When you are one square away from drop pile, you do not walk to the square, you just loot from 1 square away. You should walk onto the sqaur where the drop is, unless frozen
> You cannot sell 100m or 1b tickets to junk store
> If you put >1100m coin offer into ge, it will give you 100m less than what you put in. Eg. put in 1100m coins, it will give you 10 100m tickets back

Color x (Troll n roll) & Im on meth
> Dupe: If you put max cash (2147483647gp) in the gp while you have 100m ticket(s) in your inventory it will take 100m ticket plus 2,047,483,647gp, leaving you with 200m gp in inventory. That leaves you with a total of 2,347,483,647gp (could not reproduce)

Color x (Troll n roll) & Jonas (Pksasaftw)
> You can loot from 1 square away (doesn't run on top of pile) while unfrozen
- You can get BH target from same IP (intended testserver behavior, doesn't work in production)

Jonas (Pksasaftw) & Nolan
> A lesser demon is spawned on the lava at taverley dungeon
- You can walk through the stalagmites at the Tormented Demons (the stalagmites are actually wall objects between squares - this is how Jagex made it and how it should be)

Jonas (Pksasaftw) & Daan
> 24209 & 24210 interface id's at the bottom of trade screen

> Mod Yell doesn't show crowns, neither does helper or admin yell
> You can only withdraw 2147m coins from a bought item, it doesn't convert any of it into any tickets (Sold Torva for 13b, and it just keeps giving me 2147m everytime I try to take the money out)
> Pets won't face you if your last movement was a turn. they'll just face the way you were in your previous step
> Wise old man achievements don't actually show that they're complete
> You can refund perm curses and it'll reset it as if you never bought them
> Magic doesn't stack, the ticks are off when you switch from magic to melee
> Right clicking in the spellbook and clicking autocast doesn't work
> When you switch weapons after using magic, then back to a staff, it'll show that you're autocasting even though it's meleeing
> Certain weapons when holding, or attacking with Vanguard on bug out the boots
> Can't spec with morrigan's
- using magic with chaotic staff causes a really buggy animation (not the chaotic staff, but vanguard/trickster/battle-mage boots & gloves cause this, reported before)

> Using the 'teleport' to house teleport or using the option to enter building mode under settings while in the skillzone causes doors to appear in the area and gives you a butler that follows you around ::skilling (needs to be tested again)
> Rewards sold at Castle Wars are bought with coins and not CW tickets. Instead of 300 tickets for a halo it's 300 GP.. etc.
> Glitched movement when you trade/challenge someone
> Sometimes when a new NPC spawns or a new wave starts the NPCs will walk up to you and stop a few steps away and not even attack
> Talking to the PkP Salesman to unlock trading rights using the option "500m and 1200 Pk Points" does not work correctly
> If you drop an item under the hunter salesman at ::shops and logout and then back in it'll show the item you dropped floating in the air. This doesn't work at the shops at home or on other NPCs so it may just be this specific square. It only floats for a few seconds and then drops to the floor like it's suppose to. (not fixed but point awarded for reporting anyway)
> The lunar spell plank make doesn't work. If you click it nothing happens. On the live game it works fine.
> Mysterious emblem 1 shows up as a dragon pickaxe (or). Item ID 12746 and noted 12747. The other emblems seem fine.

The underdog
> In the normal prayerbook, if you toggle off your quickprayers, it doesn't toggle off the protect magic prayer

Jelle (Houwuh)
> my permanent curses are gone. it says i have temp curses now. not sure if intended or not.

> Whenever you enter the Wilderness without having enough timeplayed you get a message wich is an incorrect sentence
> It might be a pathing problem, but whenever you click on an NPC to perform an action (Hunter) your character will only run to the NPC if it has moved (it won't perform the Hunter action just stands still)
> Whenever you have performed an action (example: attack an NPC) and you can't get there, there are half? noclipping checks, the server notices you can't get there because something is in the way, but if your character walks back it can run throught doors/walls
> Thermonuclear Smoke Devils don't clip properly with walls
> Some textures seem to bug out a bit from a certain angle (known, Jagex's fault, can't fix but I didn't know about furnaces having it too)
> If you walk too far after noclipping for example in the skilling area, your map will crash and turn into nothing. This will only get fixed if you perform a new maploading action such as teleporting.
- Skilling zone fishing area is bugged (known, was due to outdated clients)

Rick & Im on meth
> Diagonal noclipping is back, if you walk/run diagonally and then try to stand in each other you can noclip throught walls and such.

> When buying an item in the GE above max cash, the game doesn't recognize that u have enough money when ur money is seperated in different tickets (1b,100m). I tried buying a divine with 3x 1b ticket and 10x 100m ticket and it didn't work but when i changed the 100m tickets to 1b it did

Grant (Gdawg97)
> Noted dragonfire Shield causes client to crash

> I was picking herbs and some fell to the ground (inventory full), when I tried to pick them up they acted like an unlimited stack of herbs

The builder
> Using the wildy wall on far side of black knight's fortress causes you to move north - south, not east - west across the wall. Also unable to control your npc til it finishes walking.
> Issues with the minimap not matching size of circle. Slight lines of the world behind.

> If you use "offer x" in a trade, and then attempt to use the number you chose before for another item, it'll only offer 10.
> You don't face the person that you are casting magic on
> Zaros gs has the spec animation of the GS you combine it with. i.e. zammy GS animation, but the ags special effect is shown

> On OS X, the client forces itself back open when you try to minimize it

> Commands don't work if you capitalize the first letter, i.e ::settings works but ::Settings doesn't
> If you for example write SSs, ingame it will look like SsS so the capitalization doesn't work correctly

Nerds123 & Zeaddone
> Following a player who's transformed in a big NPC leads to glitched following

> One of the bank booths at pc does not work

Dry bones537
> Walking through gardens in player-owned houses is glitchy

Kiss me bae
> When you grapple to get to the armadyl section of the GWD it often takes you to just a white screen. You have to log out then log back in to resolve it. Same with the Zamorak bridge (could not reproduce)

> You cannot buy 1B tickets
> You can't set up a treasure chest in a Player-Owned House dungeon (says you need to have the NPC)

> The dragon claws special attack only hits twice

> Titans don't get their size setting reset after detransforming

67techn9ne67 (Iron kush jc):
> When falconry hunting sometimes the falcon says its not yours and you cant collect it even when it is yours